summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKyungwoo Lee <kyulee@microsoft.com>2015-12-10 16:18:25 -0800
committerKyungwoo Lee <kyulee@microsoft.com>2015-12-11 08:19:16 -0800
commit1c472d376ac40130b78f32b62ab26dee1454c430 (patch)
tree961e0149f21b23da01d15a77e4c2cdca077431f6 /src/CMakeLists.txt
parentcb25307b3022b67cf240ff534f05778845090921 (diff)
downloadcoreclr-1c472d376ac40130b78f32b62ab26dee1454c430.tar.gz
coreclr-1c472d376ac40130b78f32b62ab26dee1454c430.tar.bz2
coreclr-1c472d376ac40130b78f32b62ab26dee1454c430.zip
Enable ILASM for *nix
This enables ILASM for x-platforms. 1. Added a bunch of warning disable options mostly due to this prebuilt asmparse.cpp 2. Create a separte entry point "main" to pass WCHAR arguments. 3. PDB (CorSymWriter) part is disabled. 4. Converting/embedding resource file to binary is disabled. 5. jkotas kindly provided a code for IsTextUnicode which is unavailable on CoreCLR.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 64d7d63f80..1046e3ded1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -86,9 +86,9 @@ add_subdirectory(ToolBox)
add_subdirectory(tools)
add_subdirectory(unwinder)
add_subdirectory(ildasm)
+add_subdirectory(ilasm)
if(WIN32)
- add_subdirectory(ilasm)
add_subdirectory(ipcman)
endif(WIN32)