summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKyungwoo Lee <kyulee@microsoft.com>2015-11-24 12:34:08 -0800
committerKyungwoo Lee <kyulee@microsoft.com>2015-11-25 11:58:52 -0800
commit1b6658714821566dd9ab78dcf1fe96fcb0f8772a (patch)
treec27daab52b3dbadd9cdf7620cb7b94ffceb2d62b /src/CMakeLists.txt
parent6936820475b8c6b66de1807b0d123c195e18b868 (diff)
downloadcoreclr-1b6658714821566dd9ab78dcf1fe96fcb0f8772a.tar.gz
coreclr-1b6658714821566dd9ab78dcf1fe96fcb0f8772a.tar.bz2
coreclr-1b6658714821566dd9ab78dcf1fe96fcb0f8772a.zip
Enable ILDASM for Windows
This enables building ILDASM with Cmake for Windows. This ILDASM now depends on CoreCLR targeting cross-platform and thus I dropped some features like GUI/PDB -- default output is console. Metadata related APIs in CoreCLR are directly exported, and used in ILDASM: MetaDataGetDispenser GetMetaDataInternalInterface GetMetaDataInternalInterfaceFromPublic GetMetaDataPublicInterfaceFromInternal The code path is diverged by a definition FEATURE_CORECLR. There are still Window specific components. Among others, resource file/dll generation is the one that should be ported.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ded1a95bbc..31c37e5a39 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -51,6 +51,7 @@ add_subdirectory(dlls)
add_subdirectory(ToolBox)
add_subdirectory(tools)
add_subdirectory(unwinder)
+add_subdirectory(ildasm)
if(WIN32)
add_subdirectory(ipcman)