summaryrefslogtreecommitdiff
path: root/packaging/coreclr.spec
diff options
context:
space:
mode:
authorJiyoung Yun <jy910.yun@samsung.com>2017-07-14 19:10:37 +0900
committerJiyoung Yun <jy910.yun@samsung.com>2017-07-18 17:46:39 +0900
commit6f95d2d5740e2ac5f0f999b013928f8b38293b1e (patch)
tree04d493171222dde6d6b6265e7484e64e5b9c87f3 /packaging/coreclr.spec
parent92edc27e907bb080dbe6259696077eb4dec73828 (diff)
downloadcoreclr-6f95d2d5740e2ac5f0f999b013928f8b38293b1e.tar.gz
coreclr-6f95d2d5740e2ac5f0f999b013928f8b38293b1e.tar.bz2
coreclr-6f95d2d5740e2ac5f0f999b013928f8b38293b1e.zip
To maintain compatibility between externally built coreclr and corefx output and obs built output. Change-Id: I1a467dcb24332ed5884add836ac8f60c01454aad Signed-off-by: Jiyoung Yun <jy910.yun@samsung.com>
Diffstat (limited to 'packaging/coreclr.spec')
-rw-r--r--packaging/coreclr.spec8
1 files changed, 2 insertions, 6 deletions
diff --git a/packaging/coreclr.spec b/packaging/coreclr.spec
index ad88d75fba..72695a0aad 100644
--- a/packaging/coreclr.spec
+++ b/packaging/coreclr.spec
@@ -173,12 +173,8 @@ done
%build
-# These flags aren't supported by clang
-export CFLAGS=$(echo $CFLAGS | sed -e "s/-Wa,-mimplicit-it=thumb//;s/-mimplicit-it=thumb//;s/-Wl,--hash-style=gnu//;s/-Wl,-O1//;s/-Wl,--as-needed//")
-export CXXFLAGS=$(echo $CXXFLAGS | sed -e "s/-integrated-as//;s/-mimplicit-it=thumb//;s/-Wl,--hash-style=gnu//;s/-Wl,-O1//;s/-Wl,--as-needed//")
-
-export CFLAGS+=" --target=%{_host} "
-export CXXFLAGS+=" --target=%{_host} "
+export CFLAGS=" --target=%{_host} "
+export CXXFLAGS=" --target=%{_host} "
%ifarch x86_64
# Even though build architectur is x86_64, it will be running on arm board.