summaryrefslogtreecommitdiff
path: root/packaging/coreclr.spec
diff options
context:
space:
mode:
authorJiyoung Yun <jy910.yun@samsung.com>2017-03-21 13:35:49 +0900
committerJiyoung Yun <jy910.yun@samsung.com>2017-03-23 11:18:14 +0900
commit07effb0939634456c07dadeb791b82605bbb055e (patch)
tree8ae3f8305e86a2bb1e258bdb78a8dd657a2a3fa2 /packaging/coreclr.spec
parentbe039f8809f44ef9300404a61b4db8f4e2536f04 (diff)
downloadcoreclr-sandbox/giuliana/x86_baselibs.tar.gz
coreclr-sandbox/giuliana/x86_baselibs.tar.bz2
coreclr-sandbox/giuliana/x86_baselibs.zip
Enable x86 build by using -64bit dependenciessandbox/giuliana/x86_baselibs
Change-Id: If74f0db1f09e20694dcd066bed5c7d04b5cb118b Signed-off-by: Jiyoung Yun <jy910.yun@samsung.com>
Diffstat (limited to 'packaging/coreclr.spec')
-rw-r--r--packaging/coreclr.spec43
1 files changed, 26 insertions, 17 deletions
diff --git a/packaging/coreclr.spec b/packaging/coreclr.spec
index 4eccad10d9..132986fa0b 100644
--- a/packaging/coreclr.spec
+++ b/packaging/coreclr.spec
@@ -1,15 +1,10 @@
%{!?dotnet_buildtype: %define dotnet_buildtype Release}
-%ifarch x86_64
-%define support_test 1
-%define skipnative 0
-%define skipmscorlib 0
-%endif
-
-%ifarch armv7l
%define support_test 1
%define skipnative 0
%define skipmscorlib 0
+%ifarch %{ix86}
+%define ?dotnet_buildtype Debug
%endif
%define dotnet_version 1.0.0
@@ -32,7 +27,7 @@ Source1003: dep_libs.tar.gz
Patch0: Add-Tizen-RuntimeID-case.patch
Patch1: Add-project.lock.json-files.patch
-ExclusiveArch: %arm x86_64
+ExcludeArch: aarch64
BuildRequires: python
BuildRequires: python-xml
@@ -49,7 +44,6 @@ BuildRequires: tizen-release
BuildRequires: cmake
BuildRequires: llvm >= 3.8
BuildRequires: llvm-devel >= 3.8
-#BuildRequires: libllvm >= 3.8
BuildRequires: clang >= 3.8
BuildRequires: clang-devel >= 3.8
BuildRequires: lldb >= 3.8
@@ -64,8 +58,6 @@ BuildRequires: pkgconfig(lttng-ust)
# The followings are suggested by Jan Kotas
Requires: libunwind
-#(if you are debugging)
-#Requires: lldb >= 3.8
%endif
%if 0%{skipmscorlib}
@@ -73,6 +65,16 @@ Requires: libunwind
%ifarch armv7l
BuildRequires: patchelf
%endif
+%ifarch %{ix86}
+BuildRequires: patchelf
+BuildRequires: glibc-64bit
+BuildRequires: libgcc-64bit
+BuildRequires: libstdc++-64bit
+BuildRequires: libunwind-64bit
+BuildRequires: libuuid-64bit
+BuildRequires: zlib-64bit
+BuildRequires: libopenssl-64bit
+%endif
%endif
%description
@@ -109,13 +111,13 @@ cp %{SOURCE1001} .
%patch1 -p1
cp %{SOURCE1000} ./
tar xf %{SOURCE1000}
-%ifarch armv7l
+%ifarch armv7l %{ix86}
%setup -T -D -a 1002
%setup -T -D -a 1003
+%ifarch armv7l
# Detect interpreter name from cross-gcc
LD_INTERPRETER=$(patchelf --print-interpreter /emul/usr/bin/gcc)
LD_RPATH=$(patchelf --print-rpath /emul/usr/bin/gcc)
-
for file in $( find ./Tools -name "dotnet" )
do
patchelf --set-interpreter ${LD_INTERPRETER} ${file}
@@ -126,6 +128,13 @@ do
patchelf --set-rpath ${LD_RPATH}:%{_builddir}/%{name}-%{version}/libicu/ ${file}
done
%endif
+%ifarch %{ix86}
+for file in $( find ./Tools ./libicu -iname "*.so" -or -iname "*.so.*" )
+do
+ patchelf --set-rpath %{_builddir}/%{name}-%{version}/libicu/ ${file}
+done
+%endif
+%endif
%endif
%build
@@ -147,9 +156,9 @@ export CLANG_HEADERS=$(clang++ -print-search-dirs 2>&1 | sed -ne '/libraries: /s
%else
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:${LLVM_LIBDIR}:${GCC_INSTALL_DIR}
export LIBRARY_PATH=$LIBRARY_PATH:${LLVM_LIBDIR}:${GCC_INSTALL_DIR}
-export CFLAGS=" -B${LLVM_LIBDIR} -B${GCC_INSTALL_DIR} -Wno-deprecated-declarations "
-export CPPFLAGS=" -B${LLVM_LIBDIR} -B${GCC_INSTALL_DIR} -Wno-deprecated-declarations "
-export CXXFLAGS=" -B${LLVM_LIBDIR} -B${GCC_INSTALL_DIR} -Wno-deprecated-declarations "
+export CFLAGS=" -B${LLVM_LIBDIR} -B${GCC_INSTALL_DIR} -Wno-deprecated-declarations -D__extern_always_inline=inline"
+export CPPFLAGS=" -B${LLVM_LIBDIR} -B${GCC_INSTALL_DIR} -Wno-deprecated-declarations -D__extern_always_inline=inline"
+export CXXFLAGS=" -B${LLVM_LIBDIR} -B${GCC_INSTALL_DIR} -Wno-deprecated-declarations -D__extern_always_inline=inline"
export CPLUS_INCLUDE_PATH="${LLVM_INCLUDEDIR}/llvm/:${LLVM_INCLUDEDIR}/llvm-c/:${CLANG_HEADERS}:${GPP_INCLUDE_PATHS}:${CLANG_INCLUDE_PATHS}"
export C_INCLUDE_PATH="${LLVM_INCLUDEDIR}/llvm-c/:%{_includedir}"
%endif
@@ -164,7 +173,7 @@ export C_INCLUDE_PATH="${LLVM_INCLUDEDIR}/llvm-c/:%{_includedir}"
%define _barch arm64
%else
-%ifarch i586
+%ifarch %{ix86}
%define _barch x86
%else