summaryrefslogtreecommitdiff
path: root/init-tools.cmd
diff options
context:
space:
mode:
authorDavis Goodin <dagood@microsoft.com>2016-02-23 20:37:36 (GMT)
committerDavis Goodin <dagood@microsoft.com>2016-03-02 18:32:03 (GMT)
commit0d71a87375bfa54af10b68b74a4c8d93430ed308 (patch)
treec19ee951b6aa6bdd9be63d609e46b223ed284782 /init-tools.cmd
parent28c6b8dacf69d374a4ac5d6a49d7f67d899c0454 (diff)
downloadcoreclr-0d71a87375bfa54af10b68b74a4c8d93430ed308.zip
coreclr-0d71a87375bfa54af10b68b74a4c8d93430ed308.tar.gz
coreclr-0d71a87375bfa54af10b68b74a4c8d93430ed308.tar.bz2
Upgrade CLI version and buildtools, and make build file changes.
Unset CORE_ROOT in environment on Windows before doing restore so that dotnet CLI doesn't try to run using binaries from the test CORE_ROOT. Restore the xunit wrapper projects in a batch rather than individually to save a lot of time. Work around xunit.runner.msbuild not having compatible package layout by ignoring errors and adding import so that a future fix will work. Hard-code C# language for generated wrapper projects: the $(Language) property wasn't set. Also Change www.myget.org to dotnet.myget.org, as we switched to enterprise myget. Add System.ObjectModel to tests\src\JIT\config\benchmark+serialize\project.json to manually upgrade it to a version that doesn't require lifting for runtime. This fixes System.ObjectModel.dll being missing from CORE_ROOT and causing the test to fail. Switch to v3 nuget feeds and sync NuGet.Configs.
Diffstat (limited to 'init-tools.cmd')
-rw-r--r--init-tools.cmd2
1 files changed, 1 insertions, 1 deletions
diff --git a/init-tools.cmd b/init-tools.cmd
index 0d41e3b..af77c7b 100644
--- a/init-tools.cmd
+++ b/init-tools.cmd
@@ -47,7 +47,7 @@ echo Installing dotnet cli...
if NOT exist "%DOTNET_PATH%" mkdir "%DOTNET_PATH%"
set /p DOTNET_VERSION=< %~dp0DotnetCLIVersion.txt
set DOTNET_ZIP_NAME=dotnet-win-x64.%DOTNET_VERSION%.zip
-set DOTNET_REMOTE_PATH=https://dotnetcli.blob.core.windows.net/dotnet/dev/Binaries/%DOTNET_VERSION%/%DOTNET_ZIP_NAME%
+set DOTNET_REMOTE_PATH=https://dotnetcli.blob.core.windows.net/dotnet/beta/Binaries/%DOTNET_VERSION%/%DOTNET_ZIP_NAME%
set DOTNET_LOCAL_PATH=%DOTNET_PATH%%DOTNET_ZIP_NAME%
echo Installing '%DOTNET_REMOTE_PATH%' to '%DOTNET_LOCAL_PATH%' >> %INIT_TOOLS_LOG%
powershell -NoProfile -ExecutionPolicy unrestricted -Command "(New-Object Net.WebClient).DownloadFile('%DOTNET_REMOTE_PATH%', '%DOTNET_LOCAL_PATH%'); Add-Type -Assembly 'System.IO.Compression.FileSystem' -ErrorVariable AddTypeErrors; if ($AddTypeErrors.Count -eq 0) { [System.IO.Compression.ZipFile]::ExtractToDirectory('%DOTNET_LOCAL_PATH%', '%DOTNET_PATH%') } else { (New-Object -com shell.application).namespace('%DOTNET_PATH%').CopyHere((new-object -com shell.application).namespace('%DOTNET_LOCAL_PATH%').Items(),16) }" >> %INIT_TOOLS_LOG%