summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRama <ramarag@microsoft.com>2015-10-08 18:53:59 -0700
committerRama <ramarag@microsoft.com>2015-10-11 18:50:39 -0700
commitff328b606c4edad13e9a211a8d89288340952f4c (patch)
tree61db95b33101397875ec50713471aa341e25cac5 /CMakeLists.txt
parent66b24ad114f991cd882387f1a3bb280c7cd6877f (diff)
downloadcoreclr-ff328b606c4edad13e9a211a8d89288340952f4c.tar.gz
coreclr-ff328b606c4edad13e9a211a8d89288340952f4c.tar.bz2
coreclr-ff328b606c4edad13e9a211a8d89288340952f4c.zip
This enables Lttng Logging for CoreClr,
The Tracepoint Providers are built as a separate shared object called libcoreclrtraceptprovider and it is available in the same directory as libcoreclr.so By Default the ability of Tracing will not be present To enable the ability of Tracing, the apps need to be run like: LD_PRELOAD=libcoreclrtraceptprovider.so ./corerun HelloWorld.exe For now to change Xplat Event Logging mechanism add any events to: <root>/src/vm/ClrEtwAll.man Then regenerate files by running : <root>/src/inc/genXplatLtnng.pl Conflicts: Documentation/building/linux-instructions.md
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa28a5f0f1..1be2864ecb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -217,6 +217,10 @@ elseif (CLR_CMAKE_PLATFORM_UNIX)
endif(WIN32)
+if (WIN32 OR CLR_CMAKE_PLATFORM_LINUX)
+ add_definitions(-DFEATURE_EVENT_TRACE=1)
+endif (WIN32 OR CLR_CMAKE_PLATFORM_LINUX)
+
if(CLR_CMAKE_PLATFORM_UNIX)
add_subdirectory(src/ToolBox/SOS/lldbplugin)
add_subdirectory(src/pal)
@@ -225,6 +229,7 @@ if(CLR_CMAKE_PLATFORM_UNIX)
add_subdirectory(src/coreclr/hosts/unixcoreconsole)
endif(CLR_CMAKE_PLATFORM_UNIX)
+
if(CLR_CMAKE_PLATFORM_DARWIN)
add_subdirectory(src/coreclr/hosts/osxbundlerun)
endif(CLR_CMAKE_PLATFORM_DARWIN)
@@ -421,10 +426,7 @@ if (WIN32)
endif(WIN32)
# Definition directives
-# The following defines were extracted from the official amd64 debug / release builds.
-if (WIN32)
- add_definitions(-DFEATURE_EVENT_TRACE=1)
-endif (WIN32)
+
if (CLR_CMAKE_PLATFORM_UNIX)
add_definitions(-DPLATFORM_UNIX=1)