summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergiy Kuryata <sergeyk@microsoft.com>2016-01-11 17:37:45 -0800
committerSergiy Kuryata <sergeyk@microsoft.com>2016-01-11 17:37:45 -0800
commitf7fc6da5a811743c38f45497cc4c22084c46cd94 (patch)
tree56644917ab52577ec76b52f21a71cdddb62b9533 /CMakeLists.txt
parente6538fcbd554009d7edb5f378bf2763652905af4 (diff)
downloadcoreclr-f7fc6da5a811743c38f45497cc4c22084c46cd94.tar.gz
coreclr-f7fc6da5a811743c38f45497cc4c22084c46cd94.tar.bz2
coreclr-f7fc6da5a811743c38f45497cc4c22084c46cd94.zip
Enable the stack-protector compiler option for the entire coreclr
codebase.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 42fae9e6f9..35a9416ffd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -308,6 +308,8 @@ if (CLR_CMAKE_PLATFORM_UNIX)
#-fms-compatibility Enable full Microsoft Visual C++ compatibility
#-fms-extensions Accept some non-standard constructs supported by the Microsoft compiler
+ add_compile_options(-fstack-protector-strong)
+
# set the CLANG sanitizer flags for debug build
if(UPPERCASE_CMAKE_BUILD_TYPE STREQUAL DEBUG OR UPPERCASE_CMAKE_BUILD_TYPE STREQUAL CHECKED)
# obtain settings from running enablesanitizers.sh