summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Kotas <jkotas@microsoft.com>2016-04-09 18:15:42 -1000
committerJan Kotas <jkotas@microsoft.com>2016-04-09 18:15:42 -1000
commitf4b8f67019928536dc1a98caea5e17221824376b (patch)
treeee56b3e99eaffe7b27306c13632097a1d2ae0c18 /CMakeLists.txt
parenta6f4d4fff16f3def2312d2418fa6699d6cb897ba (diff)
downloadcoreclr-f4b8f67019928536dc1a98caea5e17221824376b.tar.gz
coreclr-f4b8f67019928536dc1a98caea5e17221824376b.tar.bz2
coreclr-f4b8f67019928536dc1a98caea5e17221824376b.zip
Pass noexecstack option to the assembler on Linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7124970f34..c8b64c21a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -427,6 +427,10 @@ if (CLR_CMAKE_PLATFORM_UNIX)
add_compile_options(-fstack-protector-strong)
endif(CLR_CMAKE_PLATFORM_DARWIN)
+ if(CLR_CMAKE_PLATFORM_LINUX)
+ set(CMAKE_ASM_FLAGS "${CMAKE_ASM_FLAGS} -Wa,--noexecstack")
+ endif(CLR_CMAKE_PLATFORM_LINUX)
+
# set the CLANG sanitizer flags for debug build
if(UPPERCASE_CMAKE_BUILD_TYPE STREQUAL DEBUG OR UPPERCASE_CMAKE_BUILD_TYPE STREQUAL CHECKED)
# obtain settings from running enablesanitizers.sh