summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGaurav Khanna <gkhanna@microsoft.com>2016-03-04 14:47:50 -0800
committerGaurav Khanna <gkhanna@microsoft.com>2016-03-04 14:47:50 -0800
commitac9f1d18dd0a1316945f728ba4c74943dfb23a1a (patch)
tree4d2c25d4178fcbba435f17350a901c9ac3d8226b /CMakeLists.txt
parent6d71e929ccefcedd331d8fda8ca41c05c190aea2 (diff)
parentf8dfa40dc21c01e4dc297aeb4a23db22d1830506 (diff)
downloadcoreclr-ac9f1d18dd0a1316945f728ba4c74943dfb23a1a.tar.gz
coreclr-ac9f1d18dd0a1316945f728ba4c74943dfb23a1a.tar.bz2
coreclr-ac9f1d18dd0a1316945f728ba4c74943dfb23a1a.zip
Merge pull request #3507 from gkhanna79/OneCore2
Fix CRT linkages for uCRT
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f218a23905..20a167eea4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -617,8 +617,18 @@ endif (CLR_CMAKE_PLATFORM_UNIX)
# Libraries
if (WIN32)
+
+ # Define the CRT lib references that link into Desktop imports
set(STATIC_MT_CRT_LIB "libcmt$<$<OR:$<CONFIG:Debug>,$<CONFIG:Checked>>:d>.lib")
+ set(STATIC_MT_VCRT_LIB "libvcruntime$<$<OR:$<CONFIG:Debug>,$<CONFIG:Checked>>:d>.lib")
set(STATIC_MT_CPP_LIB "libcpmt$<$<OR:$<CONFIG:Debug>,$<CONFIG:Checked>>:d>.lib")
+
+ # ARM64_TODO: Enable this for Windows Arm64
+ if (NOT CLR_CMAKE_PLATFORM_ARCH_ARM64)
+ # Define the uCRT lib reference
+ set(STATIC_MT_UCRT_LIB "libucrt$<$<OR:$<CONFIG:Debug>,$<CONFIG:Checked>>:d>.lib")
+ endif()
+
endif(WIN32)
# Definition directives