summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPat Gavlin <pagavlin@microsoft.com>2016-04-14 12:57:41 -0700
committerPat Gavlin <pagavlin@microsoft.com>2016-04-14 15:21:29 -0700
commita3bb6a066eae8a7daede52ed576e8cd8d1d50780 (patch)
tree03ac73ed2dc362c487baaa2705ab864d833f0435 /CMakeLists.txt
parente63de4a0d1dd9c5ad840495579c5437a0095bea1 (diff)
downloadcoreclr-a3bb6a066eae8a7daede52ed576e8cd8d1d50780.tar.gz
coreclr-a3bb6a066eae8a7daede52ed576e8cd8d1d50780.tar.bz2
coreclr-a3bb6a066eae8a7daede52ed576e8cd8d1d50780.zip
Make it possible to build JIT32 in the OSS tree.
This change adds a new argument to build.cmd, buildjit32, that configures the build to build and link JIT32 instead of RyuJIT if the sources are available in `src/jit32`.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4317736408..71a9aabe94 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -691,6 +691,12 @@ endif()
# End of projects that require usage of platform include files
+if(WIN32 AND CLR_CMAKE_PLATFORM_ARCH_I386 AND BUILD_JIT32)
+ set(CLR_BUILD_JIT32 1)
+else()
+ set(CLR_BUILD_JIT32 0)
+endif()
+
# Enable for UNIX altjit on Windows - set(CLR_CMAKE_PLATFORM_UNIX_TARGET_AMD64 1)
# Enable for UNIX altjit on Windows - add_definitions(-DCLR_CMAKE_PLATFORM_UNIX=1)