summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Vorlicek <janvorli@microsoft.com>2015-04-01 22:14:24 +0200
committerJan Vorlicek <janvorli@microsoft.com>2015-04-01 22:14:24 +0200
commit838807429a0828a839958e3b7d392d65886c8f2e (patch)
tree73af589b27b60fc7f9e04c884f6920c76029eeda /CMakeLists.txt
parentd2b99439df48579399b5dc4d44c2709a6eb53104 (diff)
parentde8b85b643ac08d69696ad078846424b69ae651f (diff)
downloadcoreclr-838807429a0828a839958e3b7d392d65886c8f2e.tar.gz
coreclr-838807429a0828a839958e3b7d392d65886c8f2e.tar.bz2
coreclr-838807429a0828a839958e3b7d392d65886c8f2e.zip
Merge pull request #599 from janvorli/warnings-cleanup-2a
Fix next round of warning types
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd48a4b71c..9b2786fab0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -264,26 +264,23 @@ add_definitions(-DDISABLE_CONTRACTS)
add_compile_options(-ferror-limit=4096)
# Disabled warnings
-add_compile_options(-Wno-unknown-pragmas)
add_compile_options(-Wno-unused-private-field)
add_compile_options(-Wno-dangling-else)
add_compile_options(-Wno-implicit-exception-spec-mismatch)
-# Using the result of an assignment as a condition without parentheses
-add_compile_options(-Wno-parentheses)
+# A derived class defines a virtual method with the same name as its base
+# class, but different set of parameters.
add_compile_options(-Wno-overloaded-virtual)
add_compile_options(-Wno-unused-variable)
# Enum value is not handled in a switch (and there is no default clause)
# Remaining cases are in JIT only
add_compile_options(-Wno-switch)
+# Explicit constructor calls are not supported by clang (this->ClassName::ClassName())
add_compile_options(-Wno-microsoft)
# This warning is caused by comparing 'this' to NULL
add_compile_options(-Wno-tautological-compare)
+# There are constants of type BOOL used in a condition. But BOOL is defined as int
+# and so the compiler thinks that there is a mistake.
add_compile_options(-Wno-constant-logical-operand)
-add_compile_options(-Wno-unused-function)
-add_compile_options(-Wno-extra-tokens)
-add_compile_options(-Wno-self-assign)
-add_compile_options(-Wno-bitfield-constant-conversion)
-add_compile_options(-Wno-unused-value)
add_compile_options(-Wno-unknown-warning-option)