summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrian Robbins <brianrob@microsoft.com>2016-04-05 13:18:45 -0700
committerBrian Robbins <brianrob@microsoft.com>2016-04-05 13:18:45 -0700
commit7bb5305d1be68577467cd9911cbb22cdf3bab5b1 (patch)
treeb8a0f6c302f3d3ae0c18dc75207a0af5390001b3 /CMakeLists.txt
parentb54f7b545907b7b56a338a54d14b01dab937cfc1 (diff)
downloadcoreclr-7bb5305d1be68577467cd9911cbb22cdf3bab5b1.tar.gz
coreclr-7bb5305d1be68577467cd9911cbb22cdf3bab5b1.tar.bz2
coreclr-7bb5305d1be68577467cd9911cbb22cdf3bab5b1.zip
Leave function name symbols in binaries when stripping out debug information.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a4e1e41cf..57951e642b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -303,7 +303,7 @@ function(strip_symbols targetName outputFilename)
POST_BUILD
VERBATIM
COMMAND ${OBJCOPY} --only-keep-debug ${strip_source_file} ${strip_destination_file}
- COMMAND ${OBJCOPY} --strip-unneeded ${strip_source_file}
+ COMMAND ${OBJCOPY} --strip-debug ${strip_source_file}
COMMAND ${OBJCOPY} --add-gnu-debuglink=${strip_destination_file} ${strip_source_file}
COMMENT Stripping symbols from ${strip_source_file} into file ${strip_destination_file}
)