summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Kvochko <a.kvochko@samsung.com>2016-04-05 18:10:02 +0300
committerAndrey Kvochko <a.kvochko@samsung.com>2016-04-05 18:10:02 +0300
commit40fc77eb6e799ecb7afdaa912900f3463650781e (patch)
tree921a73688e19295d5b2c9ee5c4be77870643a1c3 /CMakeLists.txt
parenta91efd26f26ef7f28023380cb73ec7766cac620d (diff)
downloadcoreclr-40fc77eb6e799ecb7afdaa912900f3463650781e.tar.gz
coreclr-40fc77eb6e799ecb7afdaa912900f3463650781e.tar.bz2
coreclr-40fc77eb6e799ecb7afdaa912900f3463650781e.zip
For Issue #3785 Arm Soft FP support: arguments and return values are passed in integer registers for arm-softfp architecture.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d0f3f54389..1dabe2cdf7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,9 +35,14 @@ if(CMAKE_SYSTEM_NAME STREQUAL Linux)
set(CLR_CMAKE_PLATFORM_UNIX_TARGET_ARM 1)
# Because we don't use CMAKE_C_COMPILER/CMAKE_CXX_COMPILER to use clang
# we have to set the triple by adding a compiler argument
- add_compile_options(-target armv7-linux-gnueabihf)
add_compile_options(-mthumb)
add_compile_options(-mfpu=vfpv3)
+ if(ARM_SOFTFP)
+ add_compile_options(-mfloat-abi=softfp)
+ add_compile_options(-target armv7-linux-gnueabi)
+ else()
+ add_compile_options(-target armv7-linux-gnueabihf)
+ endif(ARM_SOFTFP)
elseif(CMAKE_SYSTEM_PROCESSOR STREQUAL aarch64)
set(CLR_CMAKE_PLATFORM_UNIX_TARGET_ARM64 1)
else()