summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBruce Forstall <brucefo@microsoft.com>2016-04-06 13:38:05 -0700
committerBruce Forstall <brucefo@microsoft.com>2016-04-06 13:38:05 -0700
commit0a88545e68de8177efa1ae911d4a6948defd68c6 (patch)
treefc56311c5fa47844ddc72287281c44b5cc49c177 /CMakeLists.txt
parentae674a6e0550fee3884e536d8aeeaa83b8155d63 (diff)
parent40fc77eb6e799ecb7afdaa912900f3463650781e (diff)
downloadcoreclr-0a88545e68de8177efa1ae911d4a6948defd68c6.tar.gz
coreclr-0a88545e68de8177efa1ae911d4a6948defd68c6.tar.bz2
coreclr-0a88545e68de8177efa1ae911d4a6948defd68c6.zip
Merge pull request #3929 from papaslavik/arm_softfp
Arm softfp For Issue #3785
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 57951e642b..472ad3c20a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,9 +35,14 @@ if(CMAKE_SYSTEM_NAME STREQUAL Linux)
set(CLR_CMAKE_PLATFORM_UNIX_TARGET_ARM 1)
# Because we don't use CMAKE_C_COMPILER/CMAKE_CXX_COMPILER to use clang
# we have to set the triple by adding a compiler argument
- add_compile_options(-target armv7-linux-gnueabihf)
add_compile_options(-mthumb)
add_compile_options(-mfpu=vfpv3)
+ if(ARM_SOFTFP)
+ add_compile_options(-mfloat-abi=softfp)
+ add_compile_options(-target armv7-linux-gnueabi)
+ else()
+ add_compile_options(-target armv7-linux-gnueabihf)
+ endif(ARM_SOFTFP)
elseif(CMAKE_SYSTEM_PROCESSOR STREQUAL aarch64)
set(CLR_CMAKE_PLATFORM_UNIX_TARGET_ARM64 1)
else()