summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBruce Forstall <brucefo@microsoft.com>2016-02-26 19:08:24 -0800
committerBruce Forstall <brucefo@microsoft.com>2016-02-26 19:08:24 -0800
commit0582ab0dcc142e84cd16e15623f37ffe76cba24d (patch)
tree0dc63493629d51ab8713f0cffc2a87745a79ebd0 /CMakeLists.txt
parent894d162e62a6028a26f6bd129a299c7694b1bf42 (diff)
downloadcoreclr-0582ab0dcc142e84cd16e15623f37ffe76cba24d.tar.gz
coreclr-0582ab0dcc142e84cd16e15623f37ffe76cba24d.tar.bz2
coreclr-0582ab0dcc142e84cd16e15623f37ffe76cba24d.zip
Remove duplicate /GS switch
Also, fix a typo.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 825dae4cb2..4547e1ea1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -412,7 +412,6 @@ if (WIN32)
add_compile_options(/Gm-) # disable minimal rebuild
add_compile_options(/EHa) # enable C++ EH (w/ SEH exceptions)
add_compile_options(/Zp8) # pack structs on 8-byte boundary
- add_compile_options(/GS) # enable security checks
add_compile_options(/Gy) # separate functions for linker
add_compile_options(/Zc:wchar_t-) # C++ language conformance: wchar_t is NOT the native type, but a typedef
add_compile_options(/Zc:forScope) # C++ language conformance: enforce Standard C++ for scoping rules
@@ -431,7 +430,7 @@ if (WIN32)
add_compile_options($<$<OR:$<CONFIG:Release>,$<CONFIG:Relwithdebinfo>>:/GL>)
add_compile_options($<$<OR:$<OR:$<CONFIG:Release>,$<CONFIG:Relwithdebinfo>>,$<CONFIG:Checked>>:/O1>)
- if (CLR_CMAKE_PLATFORM_ARCH_AMD64)
+ if (CLR_CMAKE_PLATFORM_ARCH_AMD64)
# The generator expression in the following command means that the /homeparams option is added only for debug builds
add_compile_options($<$<CONFIG:Debug>:/homeparams>) # Force parameters passed in registers to be written to the stack
endif (CLR_CMAKE_PLATFORM_ARCH_AMD64)
@@ -730,7 +729,7 @@ add_definitions(-DFEATURE_MANAGED_ETW_CHANNELS)
add_definitions(-DFEATURE_MAIN_CLR_MODULE_USES_CORE_NAME)
add_definitions(-DFEATURE_MERGE_CULTURE_SUPPORT_AND_ENGINE)
if(WIN32)
-# Disable the following or UNIX altjit on Windows
+# Disable the following for UNIX altjit on Windows
add_definitions(-DFEATURE_MERGE_JIT_AND_ENGINE)
endif(WIN32)
add_definitions(-DFEATURE_MULTICOREJIT)