summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIan Hays <ianha@microsoft.com>2016-10-24 11:04:03 -0700
committerIan Hays <ianha@microsoft.com>2016-10-24 11:04:03 -0700
commitdf09c7b50a0d8f112b67f0525b0620a7dc00355f (patch)
treef84e170b95dcb627eb5603c9a0bd52fbc02d193b /CMakeLists.txt
parentde41f232a5e90c2a0d663d9f1eb8d3abe7117188 (diff)
downloadcoreclr-df09c7b50a0d8f112b67f0525b0620a7dc00355f.tar.gz
coreclr-df09c7b50a0d8f112b67f0525b0620a7dc00355f.tar.bz2
coreclr-df09c7b50a0d8f112b67f0525b0620a7dc00355f.zip
Add CFG flag to ARM64 build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43253f9e50..2601220680 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -282,10 +282,8 @@ if (WIN32)
endforeach (Definition)
endforeach (Config)
- if(NOT CLR_CMAKE_PLATFORM_ARCH_ARM64)
- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /guard:cf")
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /guard:cf")
- endif (NOT CLR_CMAKE_PLATFORM_ARCH_ARM64)
+ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /guard:cf")
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /guard:cf")
# Incremental linking with CFG is broken until next VS release.
# This needs to be appended to the last for each build type to override the default flag.