summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVictor "Nate" Graf <nategraf1@gmail.com>2018-01-02 09:47:20 -0800
committerGitHub <noreply@github.com>2018-01-02 09:47:20 -0800
commitc1bbdae7964b19b7063074d36e6af960f0cdc3a0 (patch)
treee554fc74fbb22c6ce9dd488fb02ba4f08ee89e89 /CMakeLists.txt
parent35bba0c5b29e9dfd2744b09e577f6111ef7de9d7 (diff)
downloadcoreclr-c1bbdae7964b19b7063074d36e6af960f0cdc3a0.tar.gz
coreclr-c1bbdae7964b19b7063074d36e6af960f0cdc3a0.tar.bz2
coreclr-c1bbdae7964b19b7063074d36e6af960f0cdc3a0.zip
Retry: Enable EventPipe across Unix and Windows (#15611)
* Revert "Revert "Enable EventPipe across Unix and Windows (#14772)" (#15609)" This reverts commit 302005ca8ae14eade37ddf4ac6e900617c1c166a. * Fix ARM build break * Use more explicit references to resolve build failures * Fix compat with python3 * Disable FeaturePerfTracing on Windows as it is not ready * Disable test for incomplete functionality * Fix test diabled patterns * Add license header * Use keyword types for managed code * Add message prefix * More precisly condition generation of eventing sources * Remove erroneously added changes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index af69a2a206..0d42deb9c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,7 @@ endif (WIN32)
set(CLR_DIR ${CMAKE_CURRENT_SOURCE_DIR})
set(VM_DIR ${CMAKE_CURRENT_SOURCE_DIR}/src/vm)
set(GENERATED_INCLUDE_DIR ${CMAKE_CURRENT_BINARY_DIR}/src/inc)
+set(GENERATED_EVENTING_DIR ${CMAKE_CURRENT_BINARY_DIR}/eventing)
set(VERSION_FILE_PATH "${CMAKE_BINARY_DIR}/version.cpp")
set(CORECLR_SET_RPATH ON)