summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRahul Kumar <rahku@microsoft.com>2016-07-05 15:04:59 -0700
committerRahul Kumar <rahku@microsoft.com>2016-07-06 12:38:22 -0700
commit74870facf4fa0f70a0c2ba5ff7ec2bd349faeb32 (patch)
tree0d486e35400824e0c3534645defbb1a604d8509f /CMakeLists.txt
parent60dcd3b757532863803c302c750de79c266d651d (diff)
downloadcoreclr-74870facf4fa0f70a0c2ba5ff7ec2bd349faeb32.tar.gz
coreclr-74870facf4fa0f70a0c2ba5ff7ec2bd349faeb32.tar.bz2
coreclr-74870facf4fa0f70a0c2ba5ff7ec2bd349faeb32.zip
Fix incremental build problem for cross-components
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt39
1 files changed, 0 insertions, 39 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 22433c8c5e..56c22838df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -542,43 +542,4 @@ if(CLR_CMAKE_BUILD_TESTS)
add_subdirectory(tests)
endif(CLR_CMAKE_BUILD_TESTS)
-#----------------------------------------------------
-# Build the project again for cross target components
-# - intermediates will be placed at %__IntermediatesDir%\crosscomponents
-# - final binaries will be placed at %__CMakeBinDir%\<hostArch>
-#----------------------------------------------------
-
-if(CLR_CMAKE_PLATFORM_ARCH_ARM64 AND WIN32)
- # Cross target component build only enabled for win arm64
- set(CLR_CROSS_COMPONENTS_BUILD_ENABLED 1)
-endif()
-
-# To avoid recursion when building cross target components
-if(NOT DEFINED CLR_CROSS_COMPONENTS_BUILD AND CLR_CROSS_COMPONENTS_BUILD_ENABLED)
-
- # Set host arch for cross target components
- if(CLR_CMAKE_PLATFORM_ARCH_ARM64)
- set(CLR_CROSS_BUILD_HOST_ARCH x64)
- elseif(CLR_CMAKE_PLATFORM_ARCH_ARM)
- set(CLR_CROSS_BUILD_HOST_ARCH x86)
- endif()
-
- include(ExternalProject)
-
- # Add the source root again as external project but with CLR_CROSS_COMPONENTS_BUILD flag set
- ExternalProject_Add(
- crosscomponents
- SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}
- # Arm64 builds currently pollute the env by setting private toolset dirs. Get rid of that.
- CMAKE_COMMAND "$ENV{__VSToolsRoot}\\..\\..\\VC\\vcvarsall.bat" COMMAND cmake
- CMAKE_ARGS -DCLR_CROSS_COMPONENTS_BUILD=1
- -DCMAKE_INSTALL_PREFIX:PATH=$ENV{__CMakeBinDir}/${CLR_CROSS_BUILD_HOST_ARCH}
- -DCMAKE_USER_MAKE_RULES_OVERRIDE=${CLR_DIR}/src/pal/tools/windows-compiler-override.txt
- -DCLR_CMAKE_HOST_ARCH=${CLR_CROSS_BUILD_HOST_ARCH}
- -DCLR_CMAKE_TARGET_ARCH=${CLR_CMAKE_HOST_ARCH}
- BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/crosscomponents
- INSTALL_DIR $ENV{__CMakeBinDir}/${CLR_CROSS_BUILD_HOST_ARCH}
- )
-endif()
-
include(definitionsconsistencycheck.cmake)