summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYi Zhang (CLR) <yizhang82@users.noreply.github.com>2017-08-15 15:55:10 -0700
committerGitHub <noreply@github.com>2017-08-15 15:55:10 -0700
commit3f0dd78dba6a217f3857a8e8fecf6f81e7bc00b7 (patch)
treeb6674b0854138e6ac5fd06164ac9ccf12501dce3 /CMakeLists.txt
parentd019acaf5c6a5239f50bd4bfbf05dd02f0e42ec1 (diff)
downloadcoreclr-3f0dd78dba6a217f3857a8e8fecf6f81e7bc00b7.tar.gz
coreclr-3f0dd78dba6a217f3857a8e8fecf6f81e7bc00b7.tar.bz2
coreclr-3f0dd78dba6a217f3857a8e8fecf6f81e7bc00b7.zip
Finalize override lookup algorithm (#12753)
* first cut of multiple candidates * new positive case for diamond shape * Add proper missing implementation detection and positive diamond shape scenario support. Untested * fix bug and get test to pass * Add more diamond shape pos/neg tests * Fix bad I8 * Add GVM tests to diamond shape * GVM working * Change test case to better match diamondshape scenario * Fix MethodImpl::Iterator::GetMethodDesc and optimize no-method impl scenario * Update methodimpl test to include multiple slots and fix a bug * Temporarily disable incremental build in this branch * Update methodimpl to include multiple methodipml overriding scenario. This is triggering some bugs and need to investigate * Fix a buffer overrrun bug with interface methodimpl * Update after self-review * Add proper methodImpl validation for methods * Address feedback. Refactoring pending
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38461acaee..ff21c69f43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -344,6 +344,10 @@ if (WIN32)
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /DEBUG /PDBCOMPRESS")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /STACK:1572864")
+ # Temporarily disable incremental link due to incremental linking CFG bug crashing crossgen.
+ # See https://github.com/dotnet/coreclr/issues/12592
+ set(NO_INCREMENTAL_LINKER_FLAGS "/INCREMENTAL:NO")
+
# Debug build specific flags
set(CMAKE_SHARED_LINKER_FLAGS_DEBUG "/NOVCFEATURE ${NO_INCREMENTAL_LINKER_FLAGS}")
set(CMAKE_EXE_LINKER_FLAGS_DEBUG "${NO_INCREMENTAL_LINKER_FLAGS}")