summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOmair Majid <omair.majid@gmail.com>2017-06-02 16:55:14 -0400
committerJan Vorlicek <janvorli@microsoft.com>2017-06-02 22:55:14 +0200
commitf7ce37729328d4f1061bd8bb52e3eecb0e49486c (patch)
tree9a3022ffed67fcf666259cbaa59393814e38a122 /CMakeLists.txt
parent23126aa5b7d6dc7b58301df7d0af1ccdf805224d (diff)
downloadcoreclr-f7ce37729328d4f1061bd8bb52e3eecb0e49486c.tar.gz
coreclr-f7ce37729328d4f1061bd8bb52e3eecb0e49486c.tar.bz2
coreclr-f7ce37729328d4f1061bd8bb52e3eecb0e49486c.zip
Add support for not breaking *nix build on warnings (#12039)
Add a build flag to make -Werror optional and let the build continue even in the presence of warnings. This option is very useful for anyone compiling with a different (version of the) compiler. A different (version of the) compiler may produce a different set of warnings and a piece of code that compiles without warnings may emit warnings with a different (version of the) compiler. Resolves https://github.com/dotnet/coreclr/issues/8586
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6e0987ebe..a6511de47c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,6 +32,7 @@ if(CORECLR_SET_RPATH)
endif(CORECLR_SET_RPATH)
OPTION(CMAKE_ENABLE_CODE_COVERAGE "Enable code coverage" OFF)
+OPTION(CLR_CMAKE_WARNINGS_ARE_ERRORS "Warnings are errors" ON)
# Ensure that python is present
find_program(PYTHON python)