summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjashoo <jashoo@microsoft.com>2017-07-13 15:19:33 -0700
committerjashook <jashoo@microsoft.com>2017-07-17 09:34:09 -0700
commite5558ed36fecc9eb7f507973906e58d9ec8e32f5 (patch)
treeed7085a572ef95898f5a7bb28c5a099adf712810 /CMakeLists.txt
parent4b232d817cb2bc1d40a6816407d904581ce1067b (diff)
downloadcoreclr-e5558ed36fecc9eb7f507973906e58d9ec8e32f5.tar.gz
coreclr-e5558ed36fecc9eb7f507973906e58d9ec8e32f5.tar.bz2
coreclr-e5558ed36fecc9eb7f507973906e58d9ec8e32f5.zip
Updates the explicit location for armasm
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b85f30b852..38461acaee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,11 +52,15 @@ if (WIN32)
endif()
# Explicitly specify the assembler to be used for Arm32 compile
- file(TO_CMAKE_PATH "$ENV{VCINSTALLDIR}\\bin\\x86_arm\\armasm.exe" CMAKE_ASM_COMPILER)
-
+ if($ENV{__VSVersion} STREQUAL "vs2015")
+ file(TO_CMAKE_PATH "$ENV{VCINSTALLDIR}\\bin\\x86_arm\\armasm.exe" CMAKE_ASM_COMPILER)
+ else()
+ file(TO_CMAKE_PATH "$ENV{VCToolsInstallDir}\\bin\\HostX86\\arm\\armasm.exe" CMAKE_ASM_COMPILER)
+ endif()
+
set(CMAKE_ASM_MASM_COMPILER ${CMAKE_ASM_COMPILER})
message("CMAKE_ASM_MASM_COMPILER explicitly set to: ${CMAKE_ASM_MASM_COMPILER}")
-
+
# Enable generic assembly compilation to avoid CMake generate VS proj files that explicitly
# use ml[64].exe as the assembler.
enable_language(ASM)