summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOmair Majid <omajid@redhat.com>2019-01-31 16:09:35 -0500
committerAaron Robinson <arobins@microsoft.com>2019-01-31 13:09:34 -0800
commite7c6f87f54be723724a4c996d815d59b515b01a6 (patch)
treea051104a816a2cdd79243164b21db247510154ec /CMakeLists.txt
parent1b50d965d4a3ff23dd8d95b02d28b6a5c5cec6a2 (diff)
downloadcoreclr-e7c6f87f54be723724a4c996d815d59b515b01a6.tar.gz
coreclr-e7c6f87f54be723724a4c996d815d59b515b01a6.tar.bz2
coreclr-e7c6f87f54be723724a4c996d815d59b515b01a6.zip
Update python lookup in CMakeLists.txt to match build.(sh|cmd) (#22145)
Use the same logic that's used in build.sh/build.cmd to lookup python: first search for `python3`, then fall back to `python2` and finally to `python`.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 82c19a9cba..31b814f118 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,7 @@ OPTION(CLR_CMAKE_ENABLE_CODE_COVERAGE "Enable code coverage" OFF)
OPTION(CLR_CMAKE_WARNINGS_ARE_ERRORS "Warnings are errors" ON)
# Ensure that python is present
-find_program(PYTHON NAMES python2.7 python2 python)
+find_program(PYTHON NAMES python3 python2 python)
if (PYTHON STREQUAL "PYTHON-NOTFOUND")
message(FATAL_ERROR "PYTHON not found: Please install Python 2.7.9 or later from https://www.python.org/downloads/")
endif()