summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTomas Weinfurt <tweinfurt@yahoo.com>2017-10-03 16:42:14 -0700
committerJan Vorlicek <janvorli@microsoft.com>2017-10-04 01:42:14 +0200
commit858f5e0658a63c39eaf14c34a2146a34950c387f (patch)
tree9d22d24098decf027020c1471a7b4b0ca83096d8 /CMakeLists.txt
parentaae414026671e3dc1ccf0f308d351ac04cc746a4 (diff)
downloadcoreclr-858f5e0658a63c39eaf14c34a2146a34950c387f.tar.gz
coreclr-858f5e0658a63c39eaf14c34a2146a34950c387f.tar.bz2
coreclr-858f5e0658a63c39eaf14c34a2146a34950c387f.zip
Few build changes to support Freebsd (#14121)
* also look for python27 * add more locations to search for lldb.h so it just work on FreeBSD * add adm64 to ARCH selection. This is mostly cosmetic to avoild warning on FreeBSD * add support for -osgroup=XXX - this is mostly for conistency. -OSGroup=FreeBSD is similar to freebsdmscorlib in build.cmd * fix typo adm->amd * add back fi removed by mistake * add __HostDistroRid for FreeBSD * adress fedback from review: make python lookup consistent - starting with most specific version. uddate warning message about lldb.h and remove composite flag * feedback from review: type and small change on OSGroup syntax * few more minor fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8f77b5f783..6b4a9a4a95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,7 +35,7 @@ OPTION(CLR_CMAKE_ENABLE_CODE_COVERAGE "Enable code coverage" OFF)
OPTION(CLR_CMAKE_WARNINGS_ARE_ERRORS "Warnings are errors" ON)
# Ensure that python is present
-find_program(PYTHON python)
+find_program(PYTHON NAMES python2.7 python2 python)
if (PYTHON STREQUAL "PYTHON-NOTFOUND")
message(FATAL_ERROR "PYTHON not found: Please install Python 2.7.9 or later from https://www.python.org/downloads/")
endif()