summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Strehovský <michals@microsoft.com>2017-11-02 21:58:31 +0100
committerMichal Strehovský <michals@microsoft.com>2017-11-02 21:58:31 +0100
commitfc7225790db730e411e98c7e74f5d979b4b224f1 (patch)
treeb38440f8f1bb0ae71c749dc0b2a0aee0e1ae4755 /CMakeLists.txt
parent24f5c553ba96ece53fbc20cab0d7abe860f410bc (diff)
parent96f1a89a2bb007b7dbe5ccc613a0fa3f8dd323dd (diff)
downloadcoreclr-fc7225790db730e411e98c7e74f5d979b4b224f1.tar.gz
coreclr-fc7225790db730e411e98c7e74f5d979b4b224f1.tar.bz2
coreclr-fc7225790db730e411e98c7e74f5d979b4b224f1.zip
Merge branch 'master' into master-merge
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be792744bf..a7b450293b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,7 +35,7 @@ OPTION(CLR_CMAKE_ENABLE_CODE_COVERAGE "Enable code coverage" OFF)
OPTION(CLR_CMAKE_WARNINGS_ARE_ERRORS "Warnings are errors" ON)
# Ensure that python is present
-find_program(PYTHON python)
+find_program(PYTHON NAMES python2.7 python2 python)
if (PYTHON STREQUAL "PYTHON-NOTFOUND")
message(FATAL_ERROR "PYTHON not found: Please install Python 2.7.9 or later from https://www.python.org/downloads/")
endif()
@@ -603,10 +603,6 @@ if(FEATURE_STANDALONE_GC)
add_subdirectory(src/gc)
endif(FEATURE_STANDALONE_GC)
-if(FEATURE_STANDALONE_GC_ONLY)
- add_definitions(-DFEATURE_STANDALONE_GC_ONLY)
-endif(FEATURE_STANDALONE_GC_ONLY)
-
if (CLR_CMAKE_PLATFORM_UNIX)
include_directories("src/pal/inc")
include_directories("src/pal/inc/rt")
@@ -615,7 +611,7 @@ endif (CLR_CMAKE_PLATFORM_UNIX)
# Microsoft.Dotnet.BuildTools.Coreclr version
set(BuildToolsVersion "1.0.4-prerelease")
-set(BuildToolsDir "${CLR_DIR}/packages/Microsoft.DotNet.BuildTools.CoreCLR/${BuildToolsVersion}")
+set(BuildToolsDir "${CLR_CMAKE_PACKAGES_DIR}/Microsoft.DotNet.BuildTools.CoreCLR/${BuildToolsVersion}")
#------------------------------
# Add Product Directory