summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTanner Gooding <tagoo@outlook.com>2019-02-11 23:19:44 -0800
committerGitHub <noreply@github.com>2019-02-11 23:19:44 -0800
commitf0770609f8cdbeba019b35af48b70840f33bd479 (patch)
tree3415d53fe0cf130ca844520d614153e900c3b0bd /CMakeLists.txt
parent1c28b497ff2d49141f6a63e3f293095161e40d00 (diff)
downloadcoreclr-f0770609f8cdbeba019b35af48b70840f33bd479.tar.gz
coreclr-f0770609f8cdbeba019b35af48b70840f33bd479.tar.bz2
coreclr-f0770609f8cdbeba019b35af48b70840f33bd479.zip
Support building with VS2019 Preview (#22525)
* Support building with VS2019 Preview * Fixing gen-buildsys-win to only set the architecture for the VS generator * Refactoring Dev11/147911/fpcw.cpp so that it compiles under VS2019 * Removing the remaining traces of VS2015 build support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ac693b0be..d988ef258c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,11 +54,7 @@ if (WIN32)
endif()
# Explicitly specify the assembler to be used for Arm32 compile
- if($ENV{__VSVersion} STREQUAL "vs2015")
- file(TO_CMAKE_PATH "$ENV{VCINSTALLDIR}\\bin\\x86_arm\\armasm.exe" CMAKE_ASM_COMPILER)
- else()
- file(TO_CMAKE_PATH "$ENV{VCToolsInstallDir}\\bin\\HostX86\\arm\\armasm.exe" CMAKE_ASM_COMPILER)
- endif()
+ file(TO_CMAKE_PATH "$ENV{VCToolsInstallDir}\\bin\\HostX86\\arm\\armasm.exe" CMAKE_ASM_COMPILER)
set(CMAKE_ASM_MASM_COMPILER ${CMAKE_ASM_COMPILER})
message("CMAKE_ASM_MASM_COMPILER explicitly set to: ${CMAKE_ASM_MASM_COMPILER}")