summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJeremy Koritzinsky <jekoritz@microsoft.com>2019-05-10 16:24:42 -0700
committerGitHub <noreply@github.com>2019-05-10 16:24:42 -0700
commite985b20260631c98a09f08cb67e93d690a6ffd0b (patch)
treef78350febda1071e413382c879726f111bd62c36 /CMakeLists.txt
parent0dd7c86c8573f257cfd3b4b6374b7415fd3a9131 (diff)
downloadcoreclr-e985b20260631c98a09f08cb67e93d690a6ffd0b.tar.gz
coreclr-e985b20260631c98a09f08cb67e93d690a6ffd0b.tar.bz2
coreclr-e985b20260631c98a09f08cb67e93d690a6ffd0b.zip
Move EventProvider native layout to be driven by CMake configure (#24478)
* Generate eventpipe implementation as part of CMake configure. * Generate Etw provider as part of CMake configure. * First pass porting over lttng provider to cmake. * Fix up CMake Lttng provider generation. * Move Lttng provider into CMake tree. * Move dummy event provider to CMake * Move genEventing into the CMake tree. * Remove extraneous logging and unused python locator. * Clean up build.sh * Clean up genEventingTests.py * Add dependencies to enable more incremental builds (providers not fully incremental). * Convert to custom command and targets instead of at configure time. * Get each eventing target to incrementally build. * Fix incremental builds * Add missing dependencies on eventing headers. * PR Feedback. Mark all generated files as generated * Clean up eventprovider test CMakeLists
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d668a02ef3..7d6ba418c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,12 +36,6 @@ endif(CORECLR_SET_RPATH)
OPTION(CLR_CMAKE_ENABLE_CODE_COVERAGE "Enable code coverage" OFF)
OPTION(CLR_CMAKE_WARNINGS_ARE_ERRORS "Warnings are errors" ON)
-# Ensure that python is present
-find_program(PYTHON NAMES python3 python2 python py)
-if (PYTHON STREQUAL "PYTHON-NOTFOUND")
- message(FATAL_ERROR "PYTHON not found: Please install Python 2.7.9 or later from https://www.python.org/downloads/")
-endif()
-
# Ensure other tools are present
if (WIN32)
if(CLR_CMAKE_HOST_ARCH STREQUAL arm)