summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGaurav Khanna <gkhanna@microsoft.com>2016-01-04 09:32:26 -0800
committerGaurav Khanna <gkhanna@microsoft.com>2016-01-04 09:32:26 -0800
commit85f256e9b41cac20834d9695675e3ac8694454f9 (patch)
treea2f4372c7b628bb07bb1527ed22feaa3411b9ff0 /CMakeLists.txt
parent0c8a1ba205576c39d5dc76c32aec98c3a75af52d (diff)
parent438268f105bf9c56d4384cf531e851734c794e9c (diff)
downloadcoreclr-85f256e9b41cac20834d9695675e3ac8694454f9.tar.gz
coreclr-85f256e9b41cac20834d9695675e3ac8694454f9.tar.bz2
coreclr-85f256e9b41cac20834d9695675e3ac8694454f9.zip
Merge pull request #2474 from gkhanna79/FixArm64
Arm64 build fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bea179e91d..8d7b9cc799 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -403,10 +403,10 @@ if (WIN32)
add_compile_options($<$<OR:$<CONFIG:Release>,$<CONFIG:Relwithdebinfo>>:/GL>)
add_compile_options($<$<OR:$<OR:$<CONFIG:Release>,$<CONFIG:Relwithdebinfo>>,$<CONFIG:Checked>>:/O1>)
- if (IS_64BIT_BUILD EQUAL 1)
+ if (CLR_CMAKE_PLATFORM_ARCH_AMD64)
# The generator expression in the following command means that the /homeparams option is added only for debug builds
add_compile_options($<$<CONFIG:Debug>:/homeparams>) # Force parameters passed in registers to be written to the stack
- endif (IS_64BIT_BUILD EQUAL 1)
+ endif (CLR_CMAKE_PLATFORM_ARCH_AMD64)
# Linker flags
#