summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAditya Mandaleeka <adityamandaleeka@users.noreply.github.com>2016-04-18 12:36:53 -0700
committerAditya Mandaleeka <adityamandaleeka@users.noreply.github.com>2016-04-18 12:36:53 -0700
commit13b86edc0d28b4a91a3ec74a1d79c3d2903c94c1 (patch)
tree3ebf30507697c929130d9b8e36cf31c693e1fc67 /CMakeLists.txt
parent3666f86afb4425e42a613f11fa0af3dfb1667f58 (diff)
parentc34dabb07d321e5a3dd46f42a6c69e160b4ff3fb (diff)
downloadcoreclr-13b86edc0d28b4a91a3ec74a1d79c3d2903c94c1.tar.gz
coreclr-13b86edc0d28b4a91a3ec74a1d79c3d2903c94c1.tar.bz2
coreclr-13b86edc0d28b4a91a3ec74a1d79c3d2903c94c1.zip
Merge pull request #4370 from krytarowski/netbsd-support-64
Print message about detected NetBSD
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b30e43a42c..295ee149fd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -130,7 +130,7 @@ if(CLR_CMAKE_PLATFORM_UNIX)
# Set flag to indicate if this will be a 64bit build
# CMAKE_SYSTEM_PROCESSOR returns the value of `uname -p`.
# For the AMD/Intel 64bit architecure two different strings are common.
- # Linux and Darwin identify it as "x86_64" while FreeBSD uses the
+ # Linux and Darwin identify it as "x86_64" while FreeBSD and NetBSD use the
# "amd64" string. Accept either of the two here.
if(CMAKE_SYSTEM_PROCESSOR STREQUAL x86_64 OR CMAKE_SYSTEM_PROCESSOR STREQUAL amd64 OR CMAKE_SYSTEM_PROCESSOR STREQUAL aarch64)
set(IS_64BIT_BUILD 1)
@@ -412,6 +412,10 @@ if (CLR_CMAKE_PLATFORM_UNIX)
message("Detected FreeBSD amd64")
endif(CLR_CMAKE_PLATFORM_FREEBSD)
+ if(CLR_CMAKE_PLATFORM_NETBSD)
+ message("Detected NetBSD amd64")
+ endif(CLR_CMAKE_PLATFORM_NETBSD)
+
# Disable frame pointer optimizations so profilers can get better call stacks
add_compile_options(-fno-omit-frame-pointer)