summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHyeongseok Oh <hseok82.oh@samsung.com>2017-04-13 20:09:32 +0900
committerJan Vorlicek <janvorli@microsoft.com>2017-04-13 13:09:32 +0200
commite5faef44cac6e86b12b3b586742183293bdd34a7 (patch)
tree066f2808a9adcc6487cca8228037ceb993ffe4ec /CMakeLists.txt
parent63cf53abae162743f1b217ee0ef3bbd3c505d097 (diff)
downloadcoreclr-e5faef44cac6e86b12b3b586742183293bdd34a7.tar.gz
coreclr-e5faef44cac6e86b12b3b586742183293bdd34a7.tar.bz2
coreclr-e5faef44cac6e86b12b3b586742183293bdd34a7.zip
[ARM32/Linux] Build libcoreclrtraceptprovider.so (#10406)
* Build libcoreclrtraceptprovider.so for ARM32 and modify cmake - Build libcoreclrtraceptprovider.so for ARM32 - Include libcoreclrtraceptprovider.so in nuget package - Don't build libcoreclrtraceptprovider.so for Tizen: lttng is not supported in Tizen - Exclude packaging libcoreclrtraceptprovider.so based on os-name excluded for tizen * Remove libcoreclrtraceptprovider.so before test for ARM32/Linux Remove libcoreclrtraceptprovider.so before test for ARM32/Linux in CI CI test environment using docker with qemu has some problem to use lttng library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 257cf2dfcf..f18b67b8c4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -166,7 +166,11 @@ if(CMAKE_SYSTEM_NAME STREQUAL Linux)
# Detect Linux ID
if(DEFINED CLR_CMAKE_LINUX_ID)
- if(CLR_CMAKE_LINUX_ID STREQUAL alpine)
+ if(CLR_CMAKE_LINUX_ID STREQUAL ubuntu)
+ set(CLR_CMAKE_TARGET_UBUNTU_LINUX 1)
+ elseif(CLR_CMAKE_LINUX_ID STREQUAL tizen)
+ set(CLR_CMAKE_TARGET_TIZEN_LINUX 1)
+ elseif(CLR_CMAKE_LINUX_ID STREQUAL alpine)
set(CLR_CMAKE_PLATFORM_ALPINE_LINUX 1)
endif()
if(CLR_CMAKE_LINUX_ID STREQUAL ubuntu)