summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorConrad Meyer <cse.cem@gmail.com>2018-01-26 13:31:21 -0800
committerJan Vorlicek <janvorli@microsoft.com>2018-01-26 22:31:21 +0100
commitc8fef83569d8b39b7d8a634579d75b091980d9e9 (patch)
tree9256e228e7251c1ef42a95009417fe4da3c478d0 /CMakeLists.txt
parentd08b5fd08ea73bebe4acd1af842ef8f212429944 (diff)
downloadcoreclr-c8fef83569d8b39b7d8a634579d75b091980d9e9.tar.gz
coreclr-c8fef83569d8b39b7d8a634579d75b091980d9e9.tar.bz2
coreclr-c8fef83569d8b39b7d8a634579d75b091980d9e9.zip
Fix FreeBSD build and update build instructions (#15998)
Move test code include in global CMakeLists before PAL runtime includes to avoid conflicts between PAL and system headers. (ForeignThreadExceptionsNative.cpp -> thread -> functional -> memory -> cassert -> pal rt "assert.h".) Drop no longer needed remove_definitions lines -- they're only set by the clrdefinitions.cmake include later in the file. Update build instructions to include needed components (ninja, lttng-ust, python27). Add missing ElfW() definition when libunwind does not define it. FreeBSD alloca() is defined in stdlib.h, so include that instead of alloca.h on FreeBSD.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 7 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8057d67a28..e59995ddcf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -588,6 +588,13 @@ if(WIN32)
add_compile_options(/Zl) # omit default library name in .OBJ
endif(WIN32)
+#------------------------------
+# Add Test Directory
+#------------------------------
+if(CLR_CMAKE_BUILD_TESTS)
+ add_subdirectory(tests)
+endif(CLR_CMAKE_BUILD_TESTS)
+
#--------------------------------
# Definition directives
# - all clr specific compile definitions should be included in this file
@@ -622,16 +629,4 @@ set(BuildToolsDir "${CLR_CMAKE_PACKAGES_DIR}/Microsoft.DotNet.BuildTools.CoreCLR
#------------------------------
add_subdirectory(src)
-#------------------------------
-# Add Test Directory
-#------------------------------
-if(CLR_CMAKE_BUILD_TESTS)
- # remove some definitions for test build
- remove_definitions(-D_SECURE_SCL=0)
- remove_definitions(-DUNICODE)
- remove_definitions(-D_UNICODE)
-
- add_subdirectory(tests)
-endif(CLR_CMAKE_BUILD_TESTS)
-
include(definitionsconsistencycheck.cmake)