summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Podder <dpodder@gmail.com>2016-10-04 01:39:49 -0700
committerJan Vorlicek <janvorli@microsoft.com>2016-10-04 10:39:49 +0200
commit114b58869def96c720d0c2fd9b77ceccdc924b96 (patch)
tree91445052c408051a7582b8a891b2166162e38bc6 /CMakeLists.txt
parent4d6710d76ba222b1bf9aaef9b475a3229f827824 (diff)
downloadcoreclr-114b58869def96c720d0c2fd9b77ceccdc924b96.tar.gz
coreclr-114b58869def96c720d0c2fd9b77ceccdc924b96.tar.bz2
coreclr-114b58869def96c720d0c2fd9b77ceccdc924b96.zip
Add PGO GENPROFILE support to coreclr and clrjit (#7423)
* Add PGO GENPROFILE support to coreclr and clrjit Update the cmake build system to enable support for Profile Guided Optimization (PGO) on Windows, and enable this feature for two target binaries (coreclr and clrjit). With this change, toggle between instrumented and profile-optimized settings for target binaries by passing pgoinstrument argument to the build.cmd Assume profile-optimized mode by default. Fall back to regular non-PGO optimized builds if profile data is not available.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 140b7871be..ed55f2e3f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -496,6 +496,11 @@ if(CLR_CROSS_COMPONENTS_BUILD)
include(crosscomponents.cmake)
endif(CLR_CROSS_COMPONENTS_BUILD)
+#-------------------
+# Enable PGO support
+#-------------------
+include(pgosupport.cmake)
+
#-----------------------------------------
# Add Projects
# - project which require platform header not clr's