summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKamil Rytarowski <n54@gmx.com>2016-04-15 23:01:26 +0200
committerKamil Rytarowski <n54@gmx.com>2016-04-15 23:01:26 +0200
commitc34dabb07d321e5a3dd46f42a6c69e160b4ff3fb (patch)
treee69b927262b49d7e5ef6169f3263f047c5b4794c /CMakeLists.txt
parent02d18c9eceeb3c4e80c5c59dbc8103294adc86af (diff)
downloadcoreclr-c34dabb07d321e5a3dd46f42a6c69e160b4ff3fb.tar.gz
coreclr-c34dabb07d321e5a3dd46f42a6c69e160b4ff3fb.tar.bz2
coreclr-c34dabb07d321e5a3dd46f42a6c69e160b4ff3fb.zip
Print message about detected NetBSD
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2caeed625..e5a9af2f94 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -130,7 +130,7 @@ if(CLR_CMAKE_PLATFORM_UNIX)
# Set flag to indicate if this will be a 64bit build
# CMAKE_SYSTEM_PROCESSOR returns the value of `uname -p`.
# For the AMD/Intel 64bit architecure two different strings are common.
- # Linux and Darwin identify it as "x86_64" while FreeBSD uses the
+ # Linux and Darwin identify it as "x86_64" while FreeBSD and NetBSD use the
# "amd64" string. Accept either of the two here.
if(CMAKE_SYSTEM_PROCESSOR STREQUAL x86_64 OR CMAKE_SYSTEM_PROCESSOR STREQUAL amd64 OR CMAKE_SYSTEM_PROCESSOR STREQUAL aarch64)
set(IS_64BIT_BUILD 1)
@@ -412,6 +412,10 @@ if (CLR_CMAKE_PLATFORM_UNIX)
message("Detected FreeBSD amd64")
endif(CLR_CMAKE_PLATFORM_FREEBSD)
+ if(CLR_CMAKE_PLATFORM_NETBSD)
+ message("Detected NetBSD amd64")
+ endif(CLR_CMAKE_PLATFORM_NETBSD)
+
# Disable frame pointer optimizations so profilers can get better call stacks
add_compile_options(-fno-omit-frame-pointer)