summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGeunsik Lim <geunsik.lim@samsung.com>2016-03-05 12:05:12 +0900
committerGeunsik Lim <geunsik.lim@samsung.com>2016-03-05 12:05:12 +0900
commit6f7aa7967c607b8c667518314ab937c0d7547025 (patch)
tree862907da843c17744e5f3cb659d61f175d927afb /CMakeLists.txt
parent34e1fad44ec969a85db8464eaab3c13b406cb5a2 (diff)
downloadcoreclr-6f7aa7967c607b8c667518314ab937c0d7547025.tar.gz
coreclr-6f7aa7967c607b8c667518314ab937c0d7547025.tar.bz2
coreclr-6f7aa7967c607b8c667518314ab937c0d7547025.zip
Replace all uses of __LINUX__ with the lower case
According to https://sourceforge.net/p/predef/wiki/OperatingSystems/ (Pre-defined Compiler Macros) and http://www.faqs.org/docs/Linux-HOWTO/GCC-HOWTO.html (Porting and compiling:Automatically defined symbols), the __linux__ marcro is the right way to detect systems based on the Linux kernel and is the POSIX compliant. Signed-off-by: Geunsik Lim <geunsik.lim@samsung.com> Signed-off-by: MyungJoo Ham <myungjoo.ham@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 20a167eea4..4815662d32 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -293,7 +293,6 @@ if (CLR_CMAKE_PLATFORM_UNIX)
add_definitions(-DPLATFORM_UNIX=1)
if(CLR_CMAKE_PLATFORM_LINUX)
- add_definitions(-D__LINUX__=1)
if(CLR_CMAKE_PLATFORM_UNIX_TARGET_AMD64)
message("Detected Linux x86_64")
add_definitions(-DLINUX64)