summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKyungwoo Lee <kyulee@microsoft.com>2016-03-04 08:38:05 -0800
committerKyungwoo Lee <kyulee@microsoft.com>2016-03-04 08:40:38 -0800
commitb00684d1ee8afabb0a746feb25b70c595f3b7d32 (patch)
tree48805e2a871a45bb50ba034fca9e353aa2ecdf50 /CMakeLists.txt
parent4707152ea16ca35af2c87f43db3536001f1d0e6b (diff)
downloadcoreclr-b00684d1ee8afabb0a746feb25b70c595f3b7d32.tar.gz
coreclr-b00684d1ee8afabb0a746feb25b70c595f3b7d32.tar.bz2
coreclr-b00684d1ee8afabb0a746feb25b70c595f3b7d32.zip
Fix for disabling incremental build for ARM64
The fix (d58885c9a37d857f10d90f6db7246630d4ce8980) broke ARM64 debug build. The right fix is to disable such flag for all archs.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f4b59e8104..f218a23905 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -440,12 +440,12 @@ if (WIN32)
add_compile_options(/guard:cf)
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /guard:cf")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /guard:cf")
-
- # Incremental linking with CFG is broken until next VS release.
- # This needs to be appended to the last for each build type to override the default flag.
- set(NO_INCREMENTAL_LINKER_FLAGS "/INCREMENTAL:NO")
endif (NOT CLR_CMAKE_PLATFORM_ARCH_ARM64)
+ # Incremental linking with CFG is broken until next VS release.
+ # This needs to be appended to the last for each build type to override the default flag.
+ set(NO_INCREMENTAL_LINKER_FLAGS "/INCREMENTAL:NO")
+
# Linker flags
#
# Disable the following line for UNIX altjit on Windows