summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2017-04-13 00:34:01 -0700
committerGitHub <noreply@github.com>2017-04-13 00:34:01 -0700
commit63cf53abae162743f1b217ee0ef3bbd3c505d097 (patch)
tree85f9e8fa5d87ca1c5b6e74f7e27919d0e2a8185c /CMakeLists.txt
parent4a2298203489a9b77ebe8e5c9116de35eb62c3ca (diff)
downloadcoreclr-63cf53abae162743f1b217ee0ef3bbd3c505d097.tar.gz
coreclr-63cf53abae162743f1b217ee0ef3bbd3c505d097.tar.bz2
coreclr-63cf53abae162743f1b217ee0ef3bbd3c505d097.zip
Create ELF core dump on coreclr exceptions and signals. (#10902)
* Create ELF core dump on coreclr exceptions and signals. When coreclr aborts because of a unhandled managed exception or hardware signal, the "createdump" utility is launched if the "COMPlus_DbgEnableMiniDump" environment variable is set to "1". This utility uses the DAC enumerate memory interface to determine what memory regions should be written for the managed state plus all the normal Linux memory regions for the native state like threads, stacks, DSO, etc. There still needs some to configure some of the "policies" like the name/location of the core dump and the type of minidump (MiniDumpNormal, MiniDumpWithFullAuxiliaryState, MiniDumpWithPrivateReadWriteMemory, etc.). Currently only supported on Ubuntu Linux. Make createdump smaller by using PAL in DAC module.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4aad5a02c3..257cf2dfcf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -169,6 +169,9 @@ if(CMAKE_SYSTEM_NAME STREQUAL Linux)
if(CLR_CMAKE_LINUX_ID STREQUAL alpine)
set(CLR_CMAKE_PLATFORM_ALPINE_LINUX 1)
endif()
+ if(CLR_CMAKE_LINUX_ID STREQUAL ubuntu)
+ set(CLR_CMAKE_PLATFORM_UBUNTU_LINUX 1)
+ endif()
endif(DEFINED CLR_CMAKE_LINUX_ID)
endif(CMAKE_SYSTEM_NAME STREQUAL Linux)