summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHyeongseok Oh <hseok82.oh@samsung.com>2017-02-09 08:49:23 +0900
committerJan Vorlicek <janvorli@microsoft.com>2017-02-09 00:49:23 +0100
commit4f17d5cdd502aee33aecc1669dfd3dcdcb59ca17 (patch)
tree97c25637c92f54645ccc8ed6f58e460757ef7046 /CMakeLists.txt
parent067c94e3963c73017a167894713825c576bf4b5e (diff)
downloadcoreclr-4f17d5cdd502aee33aecc1669dfd3dcdcb59ca17.tar.gz
coreclr-4f17d5cdd502aee33aecc1669dfd3dcdcb59ca17.tar.bz2
coreclr-4f17d5cdd502aee33aecc1669dfd3dcdcb59ca17.zip
[ARM32/Linux] Fix definition and CMake for cross-architecture build (#9262)
- Fix ABI flag based on target - Exclude corefx for cross-architecture component
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bdd8135b5d..c9a75e521a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -544,9 +544,9 @@ include(pgosupport.cmake)
# - project which require platform header not clr's
# - do not depend on clr's compile definitions
#-----------------------------------------
-if(CLR_CMAKE_PLATFORM_UNIX)
+if(CLR_CMAKE_PLATFORM_UNIX AND NOT DEFINED CLR_CROSS_COMPONENTS_BUILD)
add_subdirectory(src/corefx)
-endif(CLR_CMAKE_PLATFORM_UNIX)
+endif()
if(CLR_CMAKE_PLATFORM_UNIX)
add_subdirectory(src/ToolBox/SOS/lldbplugin)