summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Vorlicek <janvorli@microsoft.com>2017-06-08 12:54:18 +0200
committerGitHub <noreply@github.com>2017-06-08 12:54:18 +0200
commit65ff5146ad706a9393133df44ad2abdfd5caa9c4 (patch)
tree9c85b7e12a54450b665e151084b28f9afa4f3b40 /CMakeLists.txt
parent5d2a54449d6b9d8fecb788e741654d7dbd992a87 (diff)
downloadcoreclr-65ff5146ad706a9393133df44ad2abdfd5caa9c4.tar.gz
coreclr-65ff5146ad706a9393133df44ad2abdfd5caa9c4.tar.bz2
coreclr-65ff5146ad706a9393133df44ad2abdfd5caa9c4.zip
Fix linker GUARD option (#11492)
I have found that the /GUARD:CF option set in the root CMakeFiles.txt was not being propagated to the Visual C++ project files generated by cmake because of a wrong casing. The CMakeFiles.txt used /guard:cf but it works correctly only if it is all upper case.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 365133c39d..b85f30b852 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -313,8 +313,8 @@ if (WIN32)
endforeach (Definition)
endforeach (Config)
- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /guard:cf")
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /guard:cf")
+ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /GUARD:CF")
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} /GUARD:CF")
# Linker flags
#