summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2015-02-23 10:09:14 -0800
committerMike McLaughlin <mikem@microsoft.com>2015-02-23 10:09:14 -0800
commitbfb8bffa32b422b538a3359af84305d47a912d6c (patch)
treeb0728d94a9ffd995ac00ed2670e370671bae23f1 /CMakeLists.txt
parent639ac0872d1491d6f7b88bddbd84b3fb36bdc62a (diff)
parent63976a08fbe6ece34a2936ebccdf735ea32044a2 (diff)
downloadcoreclr-bfb8bffa32b422b538a3359af84305d47a912d6c.tar.gz
coreclr-bfb8bffa32b422b538a3359af84305d47a912d6c.tar.bz2
coreclr-bfb8bffa32b422b538a3359af84305d47a912d6c.zip
Merge remote-tracking branch 'upstream/master' into soscommand1
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 87072d8174..25c302991d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,12 @@ if(CMAKE_SYSTEM_NAME STREQUAL Darwin)
set(CMAKE_ASM_COMPILE_OBJECT "${CMAKE_C_COMPILER} <FLAGS> <DEFINES> -o <OBJECT> -c <SOURCE>")
endif(CMAKE_SYSTEM_NAME STREQUAL Darwin)
+if(WIN32)
+ enable_language(ASM_MASM)
+else()
+ enable_language(ASM)
+endif(WIN32)
+
# Build a list of compiler definitions by putting -D in front of each define.
function(get_compile_definitions DefinitionName)
# Get the current list of definitions