summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKyungwoo Lee <kyulee@microsoft.com>2015-12-01 10:16:08 -0800
committerKyungwoo Lee <kyulee@microsoft.com>2015-12-07 06:54:12 -0800
commit823b4b7d602c2298e32f2b7961bbc739cdf5b4cd (patch)
tree4aff7653d7caf70d7e23a8ec07e9245db8d7bc9c /CMakeLists.txt
parentb313fde80475f234f4746ea2e17d269bbfe00aba (diff)
downloadcoreclr-823b4b7d602c2298e32f2b7961bbc739cdf5b4cd.tar.gz
coreclr-823b4b7d602c2298e32f2b7961bbc739cdf5b4cd.tar.bz2
coreclr-823b4b7d602c2298e32f2b7961bbc739cdf5b4cd.zip
Enable ildasm for *nix
This enables ildasm for cross-platforms. Unlike Window (where initialization is done when DLL attach), CoreCLR is explciltly hosted/initialized to get the Metadata related APIs. This also eliminates the need of setting dynamic library path. Currently, ildasm binary is assumed to be located same as CoreCLR binary. I added a simple CoreCLRLoader (not meant to run an assembly file) for just direct uses of APIs. Since I expect this library to be used for ilasm work. Resource string is also handled using a static string table based on my prior check-in. Other changes are mostly mechanic with regard to wide constant string.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d0720baa9e..38c1d0c48d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -297,6 +297,7 @@ if (CLR_CMAKE_PLATFORM_UNIX)
add_subdirectory(src/coreclr/hosts/unixcoreruncommon)
add_subdirectory(src/coreclr/hosts/unixcorerun)
add_subdirectory(src/coreclr/hosts/unixcoreconsole)
+ add_subdirectory(src/ildasm/unixcoreclrloader)
endif(CLR_CMAKE_PLATFORM_UNIX)
if(CLR_CMAKE_PLATFORM_DARWIN)