summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Vorlicek <janvorli@microsoft.com>2017-09-13 19:19:20 +0200
committerGitHub <noreply@github.com>2017-09-13 19:19:20 +0200
commitf5b7f8ba68688382e57999e33ae39f46ddadd47a (patch)
treee04f7e5ccf1b7d7924ad3023a2a834d4af91ed10 /CMakeLists.txt
parentc81f37210cd1fec54cb409c76290a82bd1a1865e (diff)
downloadcoreclr-f5b7f8ba68688382e57999e33ae39f46ddadd47a.tar.gz
coreclr-f5b7f8ba68688382e57999e33ae39f46ddadd47a.tar.bz2
coreclr-f5b7f8ba68688382e57999e33ae39f46ddadd47a.zip
Disable PAX mprotect for native executables (#13940)
This change adds marking native executables that coreclr build produces (corerun, coreconsole, crossgen, ilasm, ildasm, crashdump) to using the paxctl tool to allow them running on systems with PAX configured so that creating executable memory mappings by applications is prohibited.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e1d16dffb..5dfbc40310 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,6 +92,11 @@ else (WIN32)
if (AWK STREQUAL "AWK-NOTFOUND")
message(FATAL_ERROR "AWK not found")
endif()
+
+ # Try to locate the paxctl tool. Failure to find it is not fatal,
+ # but the generated executables won't work on a system where PAX is set
+ # to prevent applications to create executable memory mappings.
+ find_program(PAXCTL paxctl)
if (CMAKE_SYSTEM_NAME STREQUAL Darwin)