summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike McLaughlin <mikem@microsoft.com>2015-06-22 17:47:46 -0700
committerMike McLaughlin <mikem@microsoft.com>2015-07-01 17:21:13 -0700
commite2010fd083f4c4cb85a2b43c5b7d3c543cb32a20 (patch)
tree4dc56ac9e4282c405a3ea3b51e89d48691d3d500 /CMakeLists.txt
parent2219d103cc1a881f154a657dc522b496a4e3b6d1 (diff)
downloadcoreclr-e2010fd083f4c4cb85a2b43c5b7d3c543cb32a20.tar.gz
coreclr-e2010fd083f4c4cb85a2b43c5b7d3c543cb32a20.tar.bz2
coreclr-e2010fd083f4c4cb85a2b43c5b7d3c543cb32a20.zip
Generate the dac table RVA using nm at build time.
Remove the temporary PAL dac table file at runtime. Replaced it with dactablerva.h file generated at build time from the libcoreclr module. nm works across Linux, OSx and FreeBSD.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 149ae1b17a..f7872e00ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ endif()
set(CLR_DIR ${CMAKE_CURRENT_SOURCE_DIR})
set(VM_DIR ${CMAKE_CURRENT_SOURCE_DIR}/src/vm)
+set(GENERATED_INCLUDE_DIR ${CMAKE_CURRENT_BINARY_DIR}/src/inc)
if(CMAKE_SYSTEM_NAME STREQUAL Linux)
set(CLR_CMAKE_PLATFORM_UNIX 1)