summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Cormack <justin@specialbusservice.com>2015-04-24 12:28:07 +0000
committerJustin Cormack <justin@specialbusservice.com>2015-04-24 13:42:49 +0000
commit8c237e56d08a1bbcdcfefcde2102e01b8fc99024 (patch)
tree86b74a60b5a336f1e7e204556839d26129deedf6 /CMakeLists.txt
parenta7d15e0e513335e15ac4efd0c54dfa56b65dc13e (diff)
downloadcoreclr-8c237e56d08a1bbcdcfefcde2102e01b8fc99024.tar.gz
coreclr-8c237e56d08a1bbcdcfefcde2102e01b8fc99024.tar.bz2
coreclr-8c237e56d08a1bbcdcfefcde2102e01b8fc99024.zip
basic NetBSD platform support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 550b3d602f..5381f02705 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,6 +39,12 @@ if(CMAKE_SYSTEM_NAME STREQUAL OpenBSD)
set(CLR_CMAKE_PLATFORM_OPENBSD 1)
endif(CMAKE_SYSTEM_NAME STREQUAL OpenBSD)
+if(CMAKE_SYSTEM_NAME STREQUAL NetBSD)
+ set(CLR_CMAKE_PLATFORM_UNIX 1)
+ set(CLR_CMAKE_PLATFORM_UNIX_TARGET_AMD64 1)
+ set(CLR_CMAKE_PLATFORM_NETBSD 1)
+endif(CMAKE_SYSTEM_NAME STREQUAL NetBSD)
+
if(WIN32)
enable_language(ASM_MASM)
else()