summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Kotas <jkotas@microsoft.com>2015-12-06 10:21:40 -0800
committerJan Kotas <jkotas@microsoft.com>2015-12-06 10:21:40 -0800
commit18deaf9691626f01f60cf32706a064b6d1fda21c (patch)
tree1a00f471ebc979f5b718d5546766697b7197f80a /CMakeLists.txt
parent0b39c9a779c99ae35f07003a7a2775a2598254e0 (diff)
parent03fe85991f055fcad160407e8f03f6aa54112740 (diff)
downloadcoreclr-18deaf9691626f01f60cf32706a064b6d1fda21c.tar.gz
coreclr-18deaf9691626f01f60cf32706a064b6d1fda21c.tar.bz2
coreclr-18deaf9691626f01f60cf32706a064b6d1fda21c.zip
Merge pull request #2247 from mikedn/safeseh
Use /safeseh to compile x86 MASM files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2bb9e97df6..a58bb487fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -381,9 +381,6 @@ set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /MANIFEST:NO") #Do n
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /SUBSYSTEM:WINDOWS,6.00") #windows subsystem
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /LARGEADDRESSAWARE") # can handle addresses larger than 2 gigabytes
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /RELEASE") #sets the checksum in the header
-if (IS_64BIT_BUILD EQUAL 0)
-set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /SAFESEH:NO") #Image does not have Safe Exception Handlers..valid only for x86
-endif (IS_64BIT_BUILD EQUAL 0)
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /NXCOMPAT") #Compatible with Data Execution Prevention
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /DYNAMICBASE") #Use address space layout randomization
set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} /DEBUGTYPE:cv,fixup") #debugging format