summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Vorlicek <janvorli@microsoft.com>2016-03-23 18:01:31 +0100
committerJan Vorlicek <janvorli@microsoft.com>2016-04-06 12:40:53 +0200
commita9abb7b987b648cac9ab3d16ddd6ecc4e960177a (patch)
tree344aa81c630023d2c04ef227f9a473043a39ff10 /CMakeLists.txt
parent930a13c8afc2e4709d7c243be44340e4b61bfdfc (diff)
downloadcoreclr-a9abb7b987b648cac9ab3d16ddd6ecc4e960177a.tar.gz
coreclr-a9abb7b987b648cac9ab3d16ddd6ecc4e960177a.tar.bz2
coreclr-a9abb7b987b648cac9ab3d16ddd6ecc4e960177a.zip
Add header file for the hosting API
Add the header file and also modify coreruncommon.cpp to use it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba328f48be..07a45def0d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -659,16 +659,10 @@ endif()
if(CLR_CMAKE_PLATFORM_UNIX)
add_subdirectory(src/ToolBox/SOS/lldbplugin)
add_subdirectory(src/pal)
- add_subdirectory(src/coreclr/hosts/unixcoreruncommon)
- add_subdirectory(src/coreclr/hosts/unixcorerun)
- add_subdirectory(src/coreclr/hosts/unixcoreconsole)
+ add_subdirectory(src/coreclr/hosts)
add_subdirectory(src/ildasm/unixcoreclrloader)
endif(CLR_CMAKE_PLATFORM_UNIX)
-if(CLR_CMAKE_PLATFORM_DARWIN)
- add_subdirectory(src/coreclr/hosts/osxbundlerun)
-endif(CLR_CMAKE_PLATFORM_DARWIN)
-
# Add this subdir. We install the headers for the jit.
add_subdirectory(src/pal/prebuilt/inc)