summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index ac6714dd..e90f4944 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,7 +1,7 @@
plugindir = $(libdir)/connman/plugins
-plugin_LTLIBRARIES = ethernet.la bluetooth.la ipv4.la
+plugin_LTLIBRARIES = bluetooth.la ipv4.la
if LOOPBACK
plugin_LTLIBRARIES += loopback.la
@@ -9,7 +9,11 @@ plugin_LTLIBRARIES += loopback.la
loopback_la_SOURCES = loopback.c
endif
+if ETHERNET
+plugin_LTLIBRARIES += ethernet.la
+
ethernet_la_SOURCES = ethernet.c inet.h inet.c
+endif
if WIFI
plugin_LTLIBRARIES += wifi.la