summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index f2b280c2..ac6714dd 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,7 +1,7 @@
plugindir = $(libdir)/connman/plugins
-plugin_LTLIBRARIES = ethernet.la bluetooth.la ipv4.la dnsproxy.la
+plugin_LTLIBRARIES = ethernet.la bluetooth.la ipv4.la
if LOOPBACK
plugin_LTLIBRARIES += loopback.la
@@ -64,8 +64,6 @@ pppd_la_SOURCES = pppd.c
pppd_la_CFLAGS = @GLIB_CFLAGS@ -DPPPD=\"@PPPD@\"
endif
-dnsproxy_la_SOURCES = dnsproxy.c
-
if RESOLVCONF
plugin_LTLIBRARIES += resolvconf.la
@@ -73,6 +71,12 @@ resolvconf_la_SOURCES = resolvconf.c
resolvconf_la_CFLAGS = @GLIB_CFLAGS@ -DRESOLVCONF=\"@RESOLVCONF@\"
endif
+if DNSPROXY
+plugin_LTLIBRARIES += dnsproxy.la
+
+dnsproxy_la_SOURCES = dnsproxy.c
+endif
+
if POLKIT
plugin_LTLIBRARIES += polkit.la