summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 07535f74..5688e668 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -74,9 +74,14 @@ huawei_la_SOURCES = huawei.c modem.h modem.c
endif
if HSO
+if HSO_BUILTIN
+builtin_modules += hso
+builtin_sources += hso.c modem.h modem.c
+else
plugin_LTLIBRARIES += hso.la
hso_la_SOURCES = hso.c modem.h modem.c
endif
+endif
if UDHCP
if UDHCP_BUILTIN