summaryrefslogtreecommitdiff
path: root/packaging/connman.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/connman.spec')
-rwxr-xr-xpackaging/connman.spec9
1 files changed, 8 insertions, 1 deletions
diff --git a/packaging/connman.spec b/packaging/connman.spec
index 39690e63..064fec4c 100755
--- a/packaging/connman.spec
+++ b/packaging/connman.spec
@@ -4,7 +4,7 @@
Name: connman
Version: 1.29
-Release: 16
+Release: 17
License: GPL-2.0+
Summary: Connection Manager
Url: http://connman.net
@@ -34,6 +34,8 @@ Requires(preun): systemd
Requires(postun): systemd
Requires: net-config
+%define upgrade_script_path /usr/share/upgrade/scripts
+
%description
Connection Manager provides a daemon for managing Internet connections
within embedded devices running the Linux operating system.
@@ -184,6 +186,10 @@ cp COPYING %{buildroot}%{_datadir}/license/connman
cp vpn/vpn-dbus.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d/connman-vpn-dbus.conf
%endif
+#OS Upgrade
+mkdir -p %{buildroot}%{upgrade_script_path}
+cp -f scripts/connman_upgrade.sh %{buildroot}%{upgrade_script_path}
+
%post
chsmack -a 'System' /%{_localstatedir}/lib/connman
chsmack -a 'System' /%{_localstatedir}/lib/connman/settings
@@ -220,6 +226,7 @@ systemctl daemon-reload
%attr(644,root,root) %{_libdir}/systemd/system/sockets.target.wants/connman.socket
%endif
%{_datadir}/license/connman
+%{upgrade_script_path}/connman_upgrade.sh
%files test
%manifest connman.manifest