summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d8fc5ed..223e1e0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,6 +198,11 @@ if (test "${enable_polkit}" = "yes"); then
AC_MSG_ERROR(PolicyKit >= 0.7 is required))
AC_SUBST(POLKIT_CFLAGS)
AC_SUBST(POLKIT_LIBS)
+ POLKIT_DATADIR="`pkg-config --variable=policydir polkit`"
+ if (test -z "${POLKIT_DATADIR}"); then
+ POLKIT_DATADIR="${datadir}/PolicyKit/policy"
+ fi
+ AC_SUBST(POLKIT_DATADIR)
fi
AM_CONDITIONAL(POLKIT, test "${enable_polkit}" = "yes")