summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4e8895ed..c1b00147 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,7 +85,8 @@ AM_CONDITIONAL(OFONO_BUILTIN, test "${enable_ofono}" = "builtin")
AC_ARG_ENABLE(modemmgr,
AC_HELP_STRING([--enable-modemmgr], [enable Modem Manager support]),
[enable_modemmgr=${enableval}], [enable_modemmgr="no"])
-AM_CONDITIONAL(MODEMMGR, test "${enable_modemmgr}" = "yes")
+AM_CONDITIONAL(MODEMMGR, test "${enable_modemmgr}" != "no")
+AM_CONDITIONAL(MODEMMGR_BUILTIN, test "${enable_modemmgr}" = "builtin")
AC_ARG_WITH(udhcpc, AC_HELP_STRING([--with-udhcpc=PROGRAM],
[specify location of udhcpc binary]), [path_udhcpc=${withval}])